Non-Site Admins are unable to delete bulletins
Incident Report for Carousel Digital Signage
Resolved
This incident has been resolved.
Posted Jan 25, 2024 - 16:37 CST
Identified
We have received reports that some customers logged in using non-site admin accounts are unable to delete bulletins. We have identified the issue and are currently working on a fix.
Posted Jan 25, 2024 - 10:57 CST