Canva Bulletin image snapshots not working

Incident Report for Carousel Digital Signage

Update

We are aware of an issue where snapshots can not be taken of images within Canva bulletins and are working on a permanent solution. Updates will be posted to this page as they become available.
Posted Feb 25, 2026 - 08:52 CST

Investigating

We are currently investigating an issue where snapshots can not be taken of images within Canva bulletins. Updates will be posted to this page as they become available.
Posted Feb 17, 2026 - 13:42 CST
This incident affects: Canva Bulletins.