Issues with Google iCal bulletins

Incident Report for Carousel Digital Signage

Resolved

Google iCal feeds are now validating as they should.
Posted Dec 18, 2025 - 17:12 CST

Monitoring

A fix has implemented in testing environments and we are validating the results.
Posted Dec 18, 2025 - 12:07 CST

Update

We are continuing to work on a fix for this issue.
Posted Dec 18, 2025 - 09:53 CST

Update

We are continuing to work on a fix for this issue.
Posted Dec 18, 2025 - 03:03 CST

Update

We are continuing to work on a fix for this issue.
Posted Dec 17, 2025 - 18:13 CST

Identified

We have identified the issue and are working on a fix.
Posted Dec 17, 2025 - 15:18 CST

Investigating

We have identified an issue with Google iCal bulletins which prevents successful feed validation for US customers. We are currently investigating a potential fix and will advise on this page as updates become available.
Posted Dec 17, 2025 - 11:56 CST
This incident affected: Google iCal Bulletins.